首页 > V2EX > V2EX-WSL2 现已支持 Systemd
2022
09-22

V2EX-WSL2 现已支持 Systemd

charlieethan:

根据微软的官方博客: https://devblogs.microsoft.com/commandline/systemd-support-is-now-available-in-wsl ,在最新版的 WSL2 中已经支持了 Systemd ,升级的方法如下(以 Windows 商店内的 Ubuntu 发行版为例,Windows 版本为 Windows 11 22H2 ):

  • 更新 WSL 版本:wsl.exe --update

  • 查看 WSL 版本:wsl.exe --version

如果第一行显示为 WSL version: 0.67.6.0 ,则已升级到支持 systemd 的版本

  • 设置 systemd 开机自启(在 Linux 内执行以下命令):
sudo cat > /etc/wsl.conf <<EOF
[boot]
systemd=true
EOF
  • 退出 Linux 子系统,并关闭 WSL:wsl.exe --shutdown

  • 重新进入 WSL ,输入 systemctl list-unit-files --type=service ,即可检验 systemd 的运行状态

from V2EX-最新主题 https://ift.tt/SjtQHX6
V2EX-WSL2 现已支持 Systemd - 第1张  | 牛C网(NiuL.Net)
官方群组:https://t.me/niuav
牛C网:https://j1o.net
牛C网导航:https://niuc1.com
零九导航:https://09.gay

最后编辑:
作者:分享菌
这个作者貌似有点懒,什么都没有留下。

留下一个回复